CARSOUND.COM Forum
Old 06-18-2005, 10:02 AM   #1
jlm1519
Senior Member
 
jlm1519's Avatar
 
Join Date: Jun 2005
Location: Philippines
Posts: 184
Lightbulb

guys need your inputs on this one! anyone used any of these amp already?what do you think about them?

I currently am using the JBL GTO75.4 but did not like it!it shuts off whenever a song hits it's peak notes!

any tips on the Lanzar?I can get it at around USD150 equivalent here in the Philippines! hey this is a third world country! [img]smile.gif[/img]
__________________
Honda Accord '95 HX-D2/Legatia 631/Oz Matrix Elite 15" sub/ Sundown Audio/ Audison Lrx 6.9
TEAM SUNDOWN PHILIPPINES
jlm1519 is offline  
Old 06-19-2005, 06:35 AM   #2
jlm1519
Senior Member
 
jlm1519's Avatar
 
Join Date: Jun 2005
Location: Philippines
Posts: 184
Post

anyone please??????Im about to buy maybe the next two days....thanks!!!!!
__________________
Honda Accord '95 HX-D2/Legatia 631/Oz Matrix Elite 15" sub/ Sundown Audio/ Audison Lrx 6.9
TEAM SUNDOWN PHILIPPINES
jlm1519 is offline  
Old 06-20-2005, 11:01 AM   #3
jlm1519
Senior Member
 
jlm1519's Avatar
 
Join Date: Jun 2005
Location: Philippines
Posts: 184
Post

I will be looking around tomorrow.anyone please?
__________________
Honda Accord '95 HX-D2/Legatia 631/Oz Matrix Elite 15" sub/ Sundown Audio/ Audison Lrx 6.9
TEAM SUNDOWN PHILIPPINES
jlm1519 is offline  
Old 06-22-2005, 07:13 AM   #4
LBaudio
 
Posts: n/a
Post

I'm curently using Lanzar OPTI series amps (100.2, 2 x 200.2 and 2 x 500.2) and I'm very satisfied with them. Before I used JBL GTQ 400 (4 x 75W rms) amp and it worked fine but there was allways present low level hiss, the x-overs had fixed frequency and only for two channels.
 
Old 07-01-2005, 02:15 AM   #5
N2Audio
Senior Member
 
Join Date: Jan 2001
Location: Lawrence, KS USA
Posts: 176
Post

Better late than never...

I have a 1000.1D and 100.4 - the latter of which replaced a 200.2. These amps are good enough that I don't believe I will ever change amps again. I've had them for almost 3 years.
The 100.4 runs bridged to my 6.5 components and works flawlessly. I don't think I could get it to go into protection even if I wanted to.

Excellent amps.
N2Audio is offline  
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:14 AM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.